cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

403 on folder

I have a folder that I use to store settings files for powershell scripts.

To convert my site to wordpress I was forced to remove all previous files and folders on my site.

After migrating to wordpress I noved the folder with my settings files back. I can not access that folder through http.

I created a copy of the settings folder on the root of my public_html folder. From that domain I can see the folder exists but I receive a 403 error when attempting to access it.


I have attempted

verifing read permision to public.

temporarily removing my .htaccess file.

Deactivating all wordpress plugs.

 

My error log shows: AH01276: Cannot serve directory /home/ID/public_html/scanners/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.xhtml,index.wml,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.js,index.jp,index.php4,index.php3,index.php,index.phtml,index.shtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html,welcome.html) found, and server-generated directory index forbidden by Options directive

 

I understand just enough to know it has to do with directory indexing. I do not know where to start to tell a web server to allow this one folder to be visible.

Thank you for your time.

1 REPLY 1
Highlighted

Re: 403 on folder

Additional notes to mention on this issue.

I have a single folder that I would like to allow directory listing or directory browsing.
If I enable password protection for that directory, directory listing does not work. If I remove password protection it works without issue.
I am never prompted to enter a password.

.htaccess with password protection enabled. (Does Not Work)

AuthType Basic
AuthName "foldername"
AuthUserFile "filename"
require valid-user
Options +Indexes

.htaccess without password protection. (Works)
```Options +Indexes```
The directory lists without issue.

Word press V. 5.4
Wordpress Theme Lyrical
Godaddy linux server
No errors appear in my error log

 

This folder was working as intended. I migrated to a wordpress site and the folder no longer functions as expended after the migration. During migration I was forced to delete the folder and add it back.
If I test this same setup from the same server on a site that is not using wordpress it works without issue.

The behavior I am hoping to see it being requested for user ID and password. Than after entering the password seeing the directory listing.
The behavior I am seeing. I do not get a request for password. I receive a 404 error.