cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Language = geo-targetted by GoDaddy

So, my management portal appears all in Vietnamese (because I am in VN at the moment). Painful and just a little bit of extra stress that I didn't need this morning. 

Luckily google translate over the top helps me navigate to my account settings. I re-select ENGLISH (USA) as the page default language. Exit into the home admin page and bang! it shifts back in Vietnamese. Run through the process again. Frustrated. Give up. allow Google to do what GoDaddy can't seem to action.

Please have whichever young staff who enabled the geolocated language option given a talking to and then disable this function by default, or at least allow the user to choose their language preference with a flag labelled function in the top right corner so that things are not so aggravating.

Screen Shot 2019-10-24 at 11.35.59 am.png

 

1 REPLY 1
Moderator
Moderator

Re: Language = geo-targetted by GoDaddy

Hi @SaigonCharlie,

 

Welcome to the Community!

It sounds like you may have a caching issue on your browser after making this change. The language you're first shown is often determined by the IP address from which the browser request was made.

 

Before you change your country option, make sure you have no other GoDaddy tabs up that may cause the "shift" back to the prior language. You can either clear your cache, or open our website in a private/Incognito browsing window, setting the language choice to your preference. 

 

 

TLH - GoDaddy | Community Moderator
Supporting you at x.co/247support