cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

413 Request Entity Too Large

Hello

When I try to send an image with my form on my WordPress site I've got error message:

 

Failed to load resource: the server responded with a status of 413 (Request Entity Too Large)

 

How can I fix it?

18 REPLIES 18
Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 are you on managed WP or using another hosting plan?

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

I'm on Economy Linux Hosting.

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 then, you should make a file called user.ini in your root folder and put this in:

 

memory_limit = 512M
max_execution_time = 320
max_input_time = 240
post_max_size = 120M
max_input_vars = 2000
file_uploads = 6
max_file_uploads = 20
upload_max_filesize = 100M

 

Try with it and let me know.

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

No, it didn't help. Still got the same error 😞

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 if you rename the file to .user.ini ?

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

I still have an error: 413 (Request Entity Too Large)

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 by the way, you should kill all your php processes from your cpanel dashboard, and wait 5 minutes for it to take effect.

 

If it still doesn't work, you can try editing the .htaccess file, adding:

LimitRequestBody 0

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄
Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 did it work?

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

Strange because sometimes work (when file is smaller than 100kb), sometimes not. If image is bigger than 200 kb it shows error 413 and not work at all 😞

Re: 413 Request Entity Too Large

Of course, I tried many times to kill processes.

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 what are you using to upload the image? I mean, which plugin.

Also, do you have a php(dot)ini file in your root folder?

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

It's a premium plugin that do meme on the image (meme generator). Simply saves text on image. I talked with support of that plugin but they checked everything on my account and said that is hosting fault and that I must ask there how to solve it.  I don't have that file in the root.

Re: 413 Request Entity Too Large

So there is no way any one here could help me?

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 can you install query monitor plugin and post the output of your PHP errors (if any) while accessing the upload form and the environment info?

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

Ok I did what you say but no errors occur. In another hosting provider, the fixed my problem because of ModSecurity. Here is a message from them:

 

You were triggering a certain ModSecurity rule:

Code:


[Fri Jul 21 07:51:24.550261 2017] [:error] [pid 40380] [client 95.42.51.147] ModSecurity: Request body no files data length is larger than the configured limit (1048576).. Deny with code (413) [hostname "mysite.com"] [uri "/frontend-submission/"] [unique_id "WX*****"]


They disabled ModSecurity for any requests towards my url /frontend-submission/ where I'm upload photo for a meme and then everything works fine without error 413.

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 Well, mod_security is implemented for a reason. You should try contacting GoDaddy via phone, and ask them if they can disable it for you.

Here you have a list of their phone numbers.

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: 413 Request Entity Too Large

I'm from Europe and in my country (Poland) there is no chance for helping me with this kind of problem because they technical support is very poor. I start this topic here with a hope that someone helps me here. My English isn't that good to explain my issue via telephone. Is there any chance that you can send this link to my topic to technical support for someone who can help me? Or other email adress, please.

Helper VI
Helper VI

Re: 413 Request Entity Too Large

@thrax23 you can go do GoDaddy's homepage, and at the top left, you can change your viewing site to "United States" and contact them via chat.

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄