cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Ninja Forms not sending notification email

I've got ninja forms set up on my website (www.myperfectheight.com). I have the form configured correctly within the Ninja Forms plugin, but when I create a test submission it does not send a notification to my email. However, it DOES send a "Thanks for your submission" notification to the user.

 

I'm using Outlook365 and want to have the notification sent to an email I've configured with my GoDaddy domain (info@myperfectheight.com). Are there any TXT or MX records I need to change in order to have this notification email sent?

 

Any help would be much appreciated. Thanks!

1 ACCEPTED SOLUTION

@phMKT

 

So the last thing I can think of is you are blacklisted.... And you are.  Google must be blocking the receipt.  So it's not Ninja forms -- it's the IP it is sending from.

 

mph-blacklist.png

 

You'll want to contact GoDaddy support and make them aware of the above.

 

HTH! 😉

 

 

Judith
"You have to be odd to be number one." Dr. Seuss

View solution in original post

6 REPLIES 6
Super User II

@phMKT

 

Try installing an SMTP plugin and see it that resolves the issue:  Easy WP SMTP

 

HTH! 😉

Judith
"You have to be odd to be number one." Dr. Seuss

Thanks for your reply! I've tried installing quite a few SMTP plugins, Easy WP SMTP included. Is there an alternative option that you know of?

 

Thanks!

@phMKT

 

Are you sending to an email address that is @ the same domain as that of your website?  If not try that.  😉

Judith
"You have to be odd to be number one." Dr. Seuss

Yes @Muse, my domain is www.myperfectheight.com and I'm trying to have the email notification sent to info@myperfectheight.com. I have created and configured this email address and can receive mail on it from my personal gmail account. I just can't get NinjaForms to send a notification when someone fills out my contact form.

@phMKT

 

So the last thing I can think of is you are blacklisted.... And you are.  Google must be blocking the receipt.  So it's not Ninja forms -- it's the IP it is sending from.

 

mph-blacklist.png

 

You'll want to contact GoDaddy support and make them aware of the above.

 

HTH! 😉

 

 

Judith
"You have to be odd to be number one." Dr. Seuss

View solution in original post

Godaddy support says it is stored in submissions on Wordpress with no mention of forwarding capability.  Hard to believe that Godaddy has a Managed Wordpress product that does not support user contact/inquiries.