Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Plesk hosting wordpress. all plugins fail to load.

I have tried plugins - add new - install now on plugin wanted.

Then it says update failed every time for every plugin.

I downloaded the zip file from the plugin site. Tried to upload it and it failed also.

What do I do to load a plugin??

Community Manager

Hi @joelr987. Thanks for being part of GoDaddy Community! It's difficult to say why this is happening. Usually, there would be additional information with the failure. If you provide the exact text from the error or a screenshot. That may help someone suggest a solution. Hope you're able to figure it out!


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.

Installation failed: 500 Internal Server Error

Every time I try and install a plugin. I press the install plugin from the plugin menu and this is what is at the top of the page. The plug in says update failed..

When I signed up I spisificly asked if I could use plugins. I was told I can use any plug in I like but I have to use cpanel...

I restarted my hosting account because I started getting a 500 internal server error when I tried loading the website.. So now I AM Back to square 1..

I am still getting no plugins to load in even with a clean slate.

I have exactly the same problem. I have not been able to find a solution and have been tearing my hair out over this. Have reset my account twice and started all over with no success. I think it may be a PHP issue but have been unable to contact godaddy. Very frustrating

I am strugglig with the same exact thing... I have called support.  They suggest I migrate my site from Plesk to cPanel, but zero explanation of why that will solve my problem, or why I need to go thru that trouble (and it is definitely trouble).  Of course, they will do the migration for me for $99, 7-10 thank you.  Very frustrated at this point.

If you need more detail, here is problem.  I go to Plugins - Add New.  Select WooCommerce.  Click Install.  It takes unusually long to load.  Then:

Installation failed: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" ""> 500 - Internal server error. <!-- body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;} fieldset{padding:0 15px 10px 15px;} h1{font-size:2.4em;margin:0;color:#FFF;} h2{font-size:1.7em;margin:0;color:#CC0000;} h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF; background-color:#555555;} #content{margin:0 0 0 2%;position:relative;} .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} --> Server Error 500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed.

I managed to get in touch with Godaddy and they informed me that the problem has probably arisen from the fact that I use the windows hosting package rather than linux. So I have to change my hosting plan in order to rectify this.

Apparently there are problem with wordpess in the windows hosting. It is a pity that ther was no notice of this on the signup page. 

The reason is not because it's on Windows instead of Linux.

The reason is GoDaddy tech support only seems to know Linux and they don't want to have to support windows.  If they don't want to support Windows then they shouldn't offer a windows platform.

I have told GoDaddy to NEVER tell me to change platforms again.  I'm too frustrated for words at how PISSED I am.

I figured it out, at least my problem, under php settings, open_basedir, set it to none (I'm pretty sure there is a better setting, but for now, that allowed plugins to install)