cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Unable to create directory uploads/2018/03. Is its parent directory writable by the server?

I am unable to upload files to media folder through wordpress. However i can do the same via ftp.

Have any of you had similar problems ? Please help.

 

This happened only after godaddy migrated my site to new server.

 

Thanks

1 ACCEPTED SOLUTION

Not sure if you figured this out yet. I was having the same issue. On your WordPress Dashboard, go to Settings > Media. There, you will see an area where it says Uploading Files. If there is a field with what looks like a path to a directory, simply delete it and click Save Changes so it can default to your current path. Then try uploading a picture to your Media Library. That should do it. Good luck!

View solution in original post

5 REPLIES 5

Hey there senthil1! 

 

One thing worth checking is that your upload path is set properly to the wordpress default

 

wp-content/uploads

 

Since you indicated the site was migrated this might need to be changed.

 

Go into your wordpress dashboard and under settings>upload> there should be some options to set this setting to what I listed above. If it already says wp-content/uploads then the upload path may not be the issue. 

Mike L. | WebPro

Michael,

The newer version of wordpress does not have this feature and it defaults to  wp-content/uploads

It is also a multisite wp installation. For all subsites the media upload works, only for default parent site it does not. 

Do help

Can some help

Not sure if you figured this out yet. I was having the same issue. On your WordPress Dashboard, go to Settings > Media. There, you will see an area where it says Uploading Files. If there is a field with what looks like a path to a directory, simply delete it and click Save Changes so it can default to your current path. Then try uploading a picture to your Media Library. That should do it. Good luck!

View solution in original post

This worked!! Thank you!