cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Changed PHP version - mysql extensions no longer available

I have switched a cPanel hosting account from PHP 5.4(native) to PHP 5.5, and now phpinfo does not show mysql or mysqli available. They are both checked in the PHP extensions box on the same page - is there something I'm missing? Any help would be appreciated.

11 REPLIES 11
Solution

Re: Changed PHP version - mysql extensions no longer available

Answering my own question...

 

I had an old php ini file that was still on the server - deleting that and switching versions now has me on the right php version with all of the right extensions.

New

New Webiste SQL error ?

I just started a  new host i built my wordpress then i deleted it to start over again and then it came up with this error 

 

 

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

 

 

 

Please help me 

 

http://dynamicteacherskw.com/

New

Re: Changed PHP version - mysql extensions no longer available

Hi sandy_aplus,

 

Would you like to tell me where you found the old php file to delete?

I am having the same issue while trying to upgrade to PHP 5.6.

 

Thank you

Your PHP installation appears to be missing the MySQL extension which is required by WordPress error

I have the error: Your PHP installation appears to be missing the MySQL extension which is required by WordPress error

And i do not know how to solve this. Could someone help me with that?

Helper VI Helper VI
Helper VI

Re: Your PHP installation appears to be missing the MySQL extension which is required by WordPress e

@leovuong91,

What kind of hosting do you have? do you have root or sudo access?

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

Re: Your PHP installation appears to be missing the MySQL extension which is required by WordPress e

 


@JHasselbring wrote:

@leovuong91,

What kind of hosting do you have? do you have root or sudo access?

 

I use Linux plan, hosting 65$/ year, i try many ways to solve but it does not work, i just delete my SQL database and file manager to restart my Wordpress. It is my first time to buy and use the hosting, so i am totally blind with the stuff.

I have read many page on the Internet, and they told me to do that, so i followed. Then this error happens and i do not know what i have to do.


 

New

Re: Your PHP installation appears to be missing the MySQL extension which is required by WordPress e

Same error with my blog Tech Flout

Re: Changed PHP version - mysql extensions no longer available

This worked for me:

Go to WHM

Search for MultiPHP Manager

Set PHP Version

Select the domain that is not working

If it is inherited, change the PHP Version to the one you need and click Apply

After this, the PHP-FPM is available, so choose On and apply

Then it Worked!

Re: Changed PHP version - mysql extensions no longer available

Thanks! I updated Apache and had a minor heart attack. I just deleted the old php.ini file and it fixed it.

New

PHP extensions not working

Hi All,

 

I have recently acquired a domain name ;  40s20s.com and hosting with Godaddy.  I asked a Developer company to FTP a dating website to this domain and they stated that a number of PHP extensions are required including the PHP GD Library.  Even though the settings are "on" for GD as well as others for MYSQL for some reason they are not loaded.

 

For example a test.php file containing the following code shows that the PHP GD library is not installed.

 

 

<?php

if (extension_loaded('gd') && function_exists('gd_info')) {
echo " PHP GD library is installed on your web server";
}
else {
echo " PHP GD library is NOT installed on your web server";
}

?>

 

Do I have to request Godaddy to install these or is there a way to do myself ?

 

Regards

 

Seaney

New

Re: Changed PHP version - mysql extensions no longer available

I get the deleting of the old php.ini file, but I'm lost after that...where do you change versions of php and is that all I need to do??