cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Rubrek
New

Moodle installation failing from Installatron

Hi everyone,

I'm really, really new to all this, so any help would be gratefully received! I'm trying to install Moodle through Installatron, but get this error message:

 

Installing: Error: MySQL innodb_large_prefix is not enabled. 

 

I've been browsing through help topics all morning and have gotten to the idea that there's something in my.cnf that needs altering to solve this. Is this correct? If so, that leads me to problem #2: everything that I've read says that it should be in home/etc/ but there's no file there of that name.

 

There's really not much else apart from Moodle that I'm looking to do with my hosting, so again, any help even getting towards a solution is really appreciated.

 

Thanks!

2 REPLIES 2
sidustech
New

I have my Moodle working. I have Deluxe Linux Hosting with cPanel. 

 

Here is what to do. You cannot use Installatron.

 

Download
https://download.moodle.org/download.php/stable39/moodle-latest-39.zip
Unzip and put the moodle folder in /public_html

Go to your Moodle site and run the install and let it fail. (HTTP://whatever.com/moodle)

Don't let the page close, use new tabs to perform the next tasks.

 

Edit Config.php
FROM
'dbcollation' => 'utf8mb4_general_ci',
TO
'dbcollation' => 'utf8_unicode_ci'

 

In the PHP Selector in cPanel
php_setting opcache.enable

 

Edit install.php
} else if (is_dataroot_insecure()) {
and change it to
} else if (false and is_dataroot_insecure()) {

 

DO NOT ALLOW AUTOMATIC UPDATES

 

Restart the install at the bottom of the failure page.

Oh, BTW you will not be able to use extended ASCII characters in your content. So no emojis or &, % symbols etc.