cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution

SSIs not working after move from legacy Linux to cPanel

My site has been migrated from a legacy Linux server to a Linux cPanel server.  None of my Server Side Includes are working although they worked on the old system.  I've tried renaming the included file to a .shtml, added a server-parsed handler for the .dat file I had originally, and moved files to the same directory.  Nothing working and no errors generated.  Phone support worked with me for a while and then said they could not help me.  Any advice is very much appreciated.

3 REPLIES 3
Employee
Employee
Solution

Re: SSIs not working after move from legacy Linux to cPanel

  1. Log in to your cPanel control panel.
  2. Scroll down to the Advanced sections.
  3. Click the Apache Handlers section.
  4. In the Handler input box under the Create an Apache handler section type in server-parsed.
  5. In the Extension(s) input, type in .html.
  6. Click Add.

SSI is not enabled by default in cPanel, this should help you correct it.

Re: SSIs not working after move from legacy Linux to cPanel

transparent, thank you so much.  I added the server-parsed handler for the file type which I was including but not for the .html file which called it.  Once I did that, everything worked fine.  Thanks very much again for your help.

Re: SSIs not working after move from legacy Linux to cPanel

Does this mean I don't have to change each of 800+ webpages to .shtml?

 

Thanks Linda


@transparent wrote:
  1. Log in to your cPanel control panel.
  2. Scroll down to the Advanced sections.
  3. Click the Apache Handlers section.
  4. In the Handler input box under the Create an Apache handler section type in server-parsed.
  5. In the Extension(s) input, type in .html.
  6. Click Add.

SSI is not enabled by default in cPanel, this should help you correct it.